sharing.webshare.query ====================== Sent on sharing.webshare changes. .. raw:: html
Webshare share entry on the TrueNAS server.
No Additional PropertiesUnique identifier for this Webshare share.
Webshare share name.
Must be at least 1 characters long
Local server path to share by using the Webshare protocol. The path must start with /mnt/ and must be in a ZFS pool.
Must be at least 1 characters long
Dataset name component of the path (e.g., 'tank/webshare'). Null if path cannot be resolved.
Relative path component within the dataset (e.g., 'subdir/data'). Null if path cannot be resolved.
If unset, the Webshare share is not available.
If set, this share is used as the base path for user home directories. Only one share can have this enabled.
Read-only value indicating whether the share is located on a locked dataset.
Returns:
- True: The share is in a locked dataset.
- False: The share is not in a locked dataset.
- None: Lock status is not available because path locking information was not requested.
Storage tier in which the share's underlying dataset is located. This field is read-only; configure the dataset's tier via zfs.tier.dataset_set_tier.
NOTE: this is a licensed feature. Will be null if TrueNAS is unlicensed, if tiering is disabled, or if the pool has no SPECIAL vdev.
Storage performance tier for this share.
Most recent rewrite job for this share's dataset, or null if no job history exists.
Rewrite job identifier in dataset_name@job_uuid format.
Must be at least 1 characters long
ZFS dataset this job is operating on.
Must be at least 1 characters long
Unique identifier for this rewrite job.
Must be at least 1 characters long
Current lifecycle state of the job.
COMPLETE - All files in the dataset have been processed.RUNNING - Job is actively processing files.QUEUED - Job is waiting for a free execution slot (see max_concurrent_jobs).CANCELLED - Job was stopped via zfs_tier_job.cancel. Not resumable.STOPPED - Job was RUNNING but its process is no longer active (e.g. daemon restart). This state is computed on read and is never written to persistent storage.ERROR - Job halted due to an unrecoverable error. Use zfs_tier_job.recover to retry failed files.Webshare share entry on the TrueNAS server.
No Additional PropertiesUnique identifier for this Webshare share.
Webshare share name.
Must be at least 1 characters long
Local server path to share by using the Webshare protocol. The path must start with /mnt/ and must be in a ZFS pool.
Must be at least 1 characters long
Dataset name component of the path (e.g., 'tank/webshare'). Null if path cannot be resolved.
Relative path component within the dataset (e.g., 'subdir/data'). Null if path cannot be resolved.
If unset, the Webshare share is not available.
If set, this share is used as the base path for user home directories. Only one share can have this enabled.
Read-only value indicating whether the share is located on a locked dataset.
Returns:
- True: The share is in a locked dataset.
- False: The share is not in a locked dataset.
- None: Lock status is not available because path locking information was not requested.
Storage tier in which the share's underlying dataset is located. This field is read-only; configure the dataset's tier via zfs.tier.dataset_set_tier.
NOTE: this is a licensed feature. Will be null if TrueNAS is unlicensed, if tiering is disabled, or if the pool has no SPECIAL vdev.
Storage performance tier for this share.
Most recent rewrite job for this share's dataset, or null if no job history exists.
Rewrite job identifier in dataset_name@job_uuid format.
Must be at least 1 characters long
ZFS dataset this job is operating on.
Must be at least 1 characters long
Unique identifier for this rewrite job.
Must be at least 1 characters long
Current lifecycle state of the job.
COMPLETE - All files in the dataset have been processed.RUNNING - Job is actively processing files.QUEUED - Job is waiting for a free execution slot (see max_concurrent_jobs).CANCELLED - Job was stopped via zfs_tier_job.cancel. Not resumable.STOPPED - Job was RUNNING but its process is no longer active (e.g. daemon restart). This state is computed on read and is never written to persistent storage.ERROR - Job halted due to an unrecoverable error. Use zfs_tier_job.recover to retry failed files.